Follow

What Android phones are supported?

The following is a list of devices that have been tested as compatible.

* Must be running Android 5.0 (Lollipop) or newer. Devices not listed may work, but we can't guarantee it.

Samsung

  • Galaxy Note 3
  • Galaxy Note 4
  • Galaxy Note 7
  • Galaxy S®3
  • Galaxy S®4
  • Galaxy S®5
  • Galaxy S®6
  • Galaxy S®7
  • Galaxy S®8
  • Galaxy S®8 Plus
  • Galaxy Tab 4
  • Galaxy Tab Pro 12.2
  • Galaxy Tab Pro 8.4

 

Google

  • Nexus™ 6P
  • Nexus™ 5X
  • Nexus™ 6
  • Nexus™ 9
  • Nexus™ 4
  • Nexus™ 5
  • Nexus™ 7 (2nd gen 2013 ver. )
  • Pixel™

 

Motorola

  • Moto G
  • Moto X
  • Moto X Pure Edition
  • Droid Turbo

 

LG

  • G3
  • G4 / G4 Stylus
  • G5
  • V10
  • Stylo 2

 

Sony

  • Xperia™ Z
  • Xperia™ Z Ultra

 

HTC

  • HTC One® (M7)
  • HTC One® (M8)
  • HTC One® (M10)

 

OnePlus

  • OnePlus2

 

Huawei

  • P8 Lite
Was this article helpful?
1 out of 1 found this helpful
Have more questions? Submit a request

2 Comments

  • 0
    Avatar
    Pavel Kudinov

    Sony Xperia Z3 Compact on Android 6.0.1 - works!

  • 0
    Avatar
    Pedro Gonzalez Adolfi

    Motorola Moto G is not working. App doesn't even finish opening before it crashes. Tried with two diferent cellphones. Currently contacting support. Will update with results.

Article is closed for comments.